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Executive Summary 

 

This is the final version within the life of the SimSafety Project of a deliverable which has 

been a continuously updated and modified in order to accompany all system versions of 

SimSafety. It includes instructions on accessing SimSafety and navigating in it. It also 

includes short description of the features developed within the project and how they can be 

used. 

 

This System Manual can be used by project partners as a useful tool towards designing 

educational scenarios but also by adults (teachers and parents) and pupils/students 

interested in visiting and exploring SimSafety. For more information regarding the 

educational activities in SimSafety and how they can be played, see D3.6: Game Scenarios 

Manual. 

 

For this reason, this document has also been available in all partner languages. 
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1. Getting started 

1.1   Sign up 

 

In order to access the SimSafety environment, you first have to create an account. 

Visit SimSafety through our project portal in the following address: 

http://www.simsafety.eu and click on the ñSimSafetyò Entrance link on the left 

menu. You will be transferred to the following screen, from where you can signup for 

an account: 

       

Screenshot 1: Click Avatar Signup. 

 

Screenshot 2: Fill in your personal details. 

http://www.simsafety.eu/
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Screenshot 3: A confirmation e-mail will be sent upon account activation. 

 

Make sure to provide a valid email address, so that you can be notified about the 

account activation. Since every account must be approved by the system 

administrators, activation may delay up to few working days. 

 

1.2 Setup the client 

 

After your account activation you have to download and install the SimSafety client in 

order to log in. Visit again the ñSimSafetyò Entrance link through the project portal 

(http://www.simsafety.eu) or directly the following page http://simsafety-avatar.cti.gr 

and click the ñDownload Clientò link from the horizontal links menu. 

 

 

Screenshot 4: The ñDownload Clientò section.  

http://www.simsafety.eu/
http://simsafety-avatar.cti.gr/
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The next step is to click the ñSimSafety Clientò link and choose ñRunò from the popup 

menu to proceed with the installation. 

 

 

Screenshot 5: Choose ñRunò when you download the client 

 

Choose an appropriate Destination Folder to install the client software and press 

Install. 

 

Screenshot 6: Select an appropriate destination Folder. 

 

1.3 Log in 

 

After the client installation, a ñSimSafetyò labeled shortcut will appear on your 

desktop.  Double click to launch the client.  
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Screenshot 7: Open the client and add your Name, Surname and Password. 

 

 

Fill in your SimSafety account credentials and click ñLog inò to enter the environment.
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2  Basics 

2.1 Client Language 

 
Screenshot 8: The Preferences Menu 

 
The SimSafety client supports different languages for its interface. One can change 

the language setting from the Edit->Preferences menu at the first screen.  

 

2.2 Movement 

 

To move your avatar in SimSafety, use the ñupò arrow key to walk forwards and the 

ñdownò arrow key to walk backwards. The ñleftò and ñrightò keys rotate your avatar on 

the spot. Press óPage Upô to make your avatar airborne, and óPage Downô to lower it 

back to the ground. The arrow keys move your avatar in the relevant direction whilst 

flying. You can also use your mouse by clicking on buttons on the movement menu. 
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Screenshot 9: Movement Controls. 

 

2.3 Camera 

 

To change your view on screen, you can change the camera angle. Use the scroll 

wheel on the mouse to zoom in and out. If you zoom in to the maximum level then 

you will enter ómouselookô mode which allows you to look around using the mouse 

from the avatarôs perspective. Another option is to go to View > Mouselook at the top 

of the screen. To exit mouselook mode simply zoom out again using the scroll wheel, 

or press the Esc button. If you press and hold Ctrl + Alt and hold down the left mouse 

button whilst moving the mouse around, you can point the camera in all directions, 

giving a much better viewing experience. You can also use the camera movement 

tool by clicking on the buttons to move the camera around. 

 

 

Screenshot 10: Camera controls. 
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2.4 Communication 

2.4.1 Local Chat 

 

Avatars within a ten meter range of each other can communicate via the Local Chat 

text box. Type into this box and press óSayô to speak to other avatars. You can also 

choose the option óShoutô, which has a wider range if you want avatars further away 

to hear you.  

 

2.4.2 History of the Local Chat 

 

To view a history of all chat, click the ñHistoryò Button and then select ólocal chatô. 

 

 

Screenshot 11: The ñHistoryò Button. 

2.4.3 Instant Message 

 

The second way of communicating in SimSafety is via private Instant Message. Click 

the óCommunicateô button at the bottom of the screen; choose the óContactsô tab and 

then select whichever avatar you wish to talk to from the list of óFriendsô or, if you 

wish to communicate to a number of people, óGroupsô. Clicking the IM/Call button on 

the right brings up a window in which you can chat privately to another avatar. 

 

2.5 Interacting with objects 
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There are many objects within SimSafety that are scripted to allow interaction 

between the object and the avatar; for example, touching a door will open it. These 

objects can be interacted with by right clicking and selecting óTouchô from the menu, 

or simply by left clicking. To sit on an object, right click and select óSit Hereô from the 

menu. 

 

Objects occasionally also give note cards or objects when you touch them. When 

touching an object that offers an object, you can touch either óKeepô or óDiscardô. 

Choosing the option óKeepô stores the object in your inventory.  
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3 Beyond Basics 

3.1 Environment Editor 

Once logging in, player can change the environment settings by accessing the 

Environment Editor through the World->Environment Setting->Environment Editor  

menu. 

 

 
Screenshot 12: Environment Editor 

 

3.2 Edit your appearance 

 

Editing your appearance is a simple process that can be performed by any player in 

the game. In order to do so, you must first make sure that your avatar is wearing 

suitable items that can be edited to create a custom appearance. Such items can be 

created through the playerôs inventory menu, found at the bottom controls menu in 

the viewer.  

  

Screenshot 13: Menus for editing your appearance. 
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Right click on the ñBody Partsò and ñClothingò tabs lets you create new body parts 

and clothes. Then double click the created items to wear them. Finally right click on 

the avatar and choose appearance from the menu to open the ñAppearanceò tab. 

There you can play with all the options regarding your appearance and customize 

your avatar as much as you see fit. 

 

 

Screenshot 14: Editing your appearance. 

 

3.3 Building 

 

The Opensim Viewer provides tools for building and modifying objects, so no 

additional software is required. These tools are relatively simple and do not contain 

the advanced options provided by dedicated 3D modeling suites. This approach 

ensures that it is relatively simple to build basic objects, although a certain amount of 

ingenuity and creative thought is required to model more complex shapes using the 

basic tools available. In order to build, it is necessary to have access to land on which 

building is permitted. Such an area is the Free Building Zone where players can try 

building whatever they like. Objects in Opensim are constructed out of constituent 

parts known as primitives, or óprimsô. There are 15 basic prim shapes (Cube, Prism, 

Pyramid, Tetrahedron, Cylinder, Hemicylinder, Cone, Hemicone,  Sphere, 

Hemisphere, Torus, Tube, Ring, Tree, Grass) which can be selected from the 

Opensim Viewer building interface. 

 



SimSafety:   D3.5 143689- GR-2008-KA3-KA3MP 

 

24/11/2010  RACTI 

 

14 

Having created an instance of a prim, numerous modifiers can be applied to alter its 

size, form, position and orientation. Objects can be moved using the axes displayed 

around the object when it is selected for editing. Holding the Ctrl key changes these 

move handle axes into rotate handles, and holding Ctrl and Shift brings up stretch 

handles. With these handles displayed the mouse can be used to manipulate the 

object. Further transformations such as twists, shears and hollowing can be applied 

by modifying the parameters under the Object tab on the building dialog box. 
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4 Things to do 

4.1 Welcome Area 

Player that visit SimSafety for the first time are teleported to the Welcome area where 

they receive information regarding the basic controls of the game. 

 

 
Screenshot 15: Welcome Area 

 

4.2 Maps 

Player will find several maps throughout the SimSafety environment. Points of 

interest are highlighted on these maps and offer teleporting by simply clicking on 

them. 
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Screenshot 16: Map 

4.3 Content presentation areas 

 

 

Screenshot 17: The ñInfo Centreò. 

Special buildings have been created in-game, where safety-related content can be 

presented. 

 

Screenshot 18: The ñMultilingualò Info Centre. 
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4.4 Quiz 

 

Players can test their Internet Safety knowledge and understanding by answering 

some simple questions. The quiz is performed with a series of multiple answer 

questions. 

 

 

Screenshot 19: The ñQuizò. 

 

According to the user answers a quiz score is calculated, which indicates whether the 

player made the right or the wrong choices. 

 

4.5 Social network simulation 

 

Internet social networks are simulated in SimSafety using the "Friends" functionality. 

 

 

Screenshot 20: The list of ñFriendsò. 
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Friend requests can be sent and received between avatars in SimSafety. 

 

Screenshot 21: A ñFriend Requestò. 

4.6 Cyber-bullying simulation 

 

Cyber-bullying is simulated in SimSafety using modules. Using the "Random Bully" 

option of the "Entrance point", bully phrases can be added to the game. 

 

This system randomly disturbs on-line players. It chooses the targets with a 5% 

chance and then uses a fake name in order to send messages to them. The 

nationality of each player is also been taken into account, so the systems chooses 

appropriate names and phrases depending on each playerôs country of origin. 

 

 

Screenshot 22: Bulling phrases in all partner languages. 
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Screenshot 23: The ñBully Reportingò Department. 

 

Players that are being bullied by the system should report the bullyôs name to the 

"Reporting Department" in-game. 

 

Screenshot 24: The ñinsideò of the ñBully Reportingò Department. 
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Screenshot 25: Reporting Bullying. 

 

After answering a couple of questions the report is made and points are being 

awarded. 

 

4.7 3D Puzzles 

Internet Safety related posters are scrambled and the players can try solving the 

puzzles. 

 

 
Screenshot 26: The ñ3D Puzzlesò. 
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4.8 Mini-Games 

In the mini-games zone, players can register to play one of the three mini-games 

provided there.  

 

 
Screenshot 27: The ñmini-gamesò zone. 

 

4.9 Gadgets 

Small gadgets have been scattered through SimSafety. Players can interact with 

them using the left mouse click. 

 

 
Screenshot 28: The ñcredit cardò gadget. 
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4.10  Wall 

Inside SimSafety, players can leave messages on a wall. Instructions on how to 

access this feature are written on the wall. 

 

 
Screenshot 29: The ñwallò zone. 

 

4.11 Free Building Zone 

 

A special area has been implemented where all users have full building permissions. 

 

 

Screenshot 30: The ñfree buildingò zone. 
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There is a variety of basic shapes that can be combined to create any shape the user 

would like. 

 

Screenshot 31: Building an object. 

 

The creativity area is tightly supervised, in order to avoid any offensive content 

created by the players. 

 

4.12  Video Content 

In order to watch the video content provided within SimSafety, you should also have 

installed on your computer Apple QuickTime Player. 

 
Screenshot 32: Video 
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4.13  Instruction for playing a Mini - Game 

 

Apply for the mini ï game by visiting mini-game section area as shown in the 

following picture: 

 

 
Screenshot 33: Game Areas are situated inside the Mini Games Zone. 

 

 
Screenshot 34: A Game Area on the outside 

 

 Sign in to the registration book which is on the teacherôs desk (just click on it with 

your mouse). 

 


